Knowledgebase
Google Contacts synchronization failed - Contacts API is being deprecated
Posted by Olivia Rust on 28 June 2021 13:23

On June 15th, 2021 Google phased out the Google Contacts API, which is a protocol we used for synchronizing Google contacts in older versions of eM Client. If you are still running one of these versions, you will encounter this error: 

[Google Contacts] Synchronizing folder 'xxx@gmail.com/Contacts' failed due to the following error: Execution of request failed:
(Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.goog.ecom/people/contacts-api-migration.)


We have switched to the current People API in eM Client 8.2, so if you are running any of the older versions, you need to either install the update (if your license is valid for eM Client 8) or upgrade your license and then install it.

You can of course keep using the older version if you prefer, but you will not be able to synchronize your Google contacts anymore, they will only be stored locally as they are.
To avoid the error pop-up, you can work around this situation by copying the contacts to Local Folders and switch off the Google Contacts service in Accounts settings.

(5 vote(s))
Helpful
Not helpful